Unity Manual User Guide Asset Import and Creation Asset Server Guide

Asset Server - Przewodnik (Tylko wersja Pro)

Unity Asset Server - Przegląd

Unity Asset Server aktywem z wersją kontroli graficznego interfejsu użytkownika zintegrowanego z Unity. Jest on przeznaczony do wykorzystywania przez członków zespołu pracujących razem nad jednym projektem na różnych komputerach lub zdalnie. Asset Server jest wysoce zoptymalizowany do obsługi dużych binarnie aktywów w celu poradzenia sobie z wieloma dużymi gigabajtowymi folderami projektu. Kiedy uploadujemy aktywa, to ustawienia importu i inne metadane dotyczące składnika/składników aktywów zostaną wysłane również na Asset Server. Zmiana nazwy i przenoszenie plików odbywa się wewnątrz systemy i jest dobrze wspierane.

Jest on dostępny tylko dla wersji Unity Pro, i jest dodatkowa licencja na klienta. Aby zakupić licencję Asset Server Client License odwiedź sklep Unity: store.unity3d.com

Nowy w kontroli źródła?

Jeśli nie używałeś nigdy wcześniej kontroli źródła może to być trochę nieprzyjazny początek z dowolną wersją systemu. Kontrola źródła działa poprzez przechowywanie całej kolekcji wszystkich twoich aktywów: siatki, tekstury, materiały, skrypty i wszystkie inne, w bazie danych na jakimś serwerze. Serwerem może być twój komputer w domu, ten sam, który służy do uruchomienia Unity. To może być inny komputer podłączony do sieci lokalnej. To może być zdalny komputer współpracujący z nimi umieszczony w innej części świata. To może być nawet maszyna wirtualna. Istnieje wiele opcji, ale lokalizacja serwera nie ma znaczenia. Ważną rzeczą jest to, że można połączyć się za pośrednictwem sieci i że zapisuje dane gry/projektu.

W pewnym sensie, Asset Server funkcjonuje jako kopia zapasowa twojego folderu z projektem. Nie bezpośrednio manipulujesz zawartością na serwerze aktywów podczas pracy. Wprowadzasz zmiany do projektu lokalnie, a następnie gdy skończysz możesz dokonać zmian w projekcie na serwerze. To sprawia, że projekt lokalny i projekt z serwera jest identyczny.

Teraz kiedy koledzy deweloperzy wprowadzą zmiany, Asset Server jest identyczny jak ich projekt, ale nie jak twój. Aby zsynchronizować projekt lokalny z tym na serwerze przeprowadź aktualizację z serwera. Teraz niezależnie od zmian od zmian które członkowie zespołu uczynili zostaną pobrane one z serwera do lokalnego projektu.

Są to podstawy przepływu pracy z wykorzystaniem Asset Server-a. Oprócz tej podstawowej funkcjonalności, Asset Server pozwala cofnąć do poprzedniej wersji aktywa, porównać szczegółowo pliki, połączyć dwa różne skrypty, rozwiązywać konflikty i odzyskiwać skasowane aktywa.

Konfiguracja Asset Server

Asset Server wymaga konfiguracji ustawień czasu serwera i konfiguracji klienta dla każdego użytkownika. Możesz przeczytać o tym jak to zrobić tutaj: Asset Server - Konfiguracja.

Reszta tego podręcznika wyjaśnia jak wdrążyć, administrować i regularnie korzystać z Asset Server.

Codzienne korzystanie z Asset Server

W tym rozdziale opisano typowe zadania, przepływ zdarzeń i najlepsze praktyki dotyczące korzystania z Asset Server na podstawie z dnia na dzień.

Jak zacząć

Jeśli dołączyłeś do zespołu, który większość swojej pracy ma przechowywane już na serwerze to najszybszy sposób by rozpocząć pracę.Jeśli zaczynasz swój własny projekt od podstaw możesz przejść niżej do sekcji Podstawy pracy.

  1. Stwórz nowy pusty projekt, bez importowania do niego aktywów
  2. Idź do Edit→Project Settings→Editor i wybierz Asset Server jako tryb kontroli wersji
  3. Z górnego menu wybierz opcję Window→Version
  4. Kliknij przycisk Connection
  5. Wpisz nazwę użytkownika i hasło (podane przez administratora serwera aktywów)
  6. Kliknij Show Projects i wybierz projekt
  7. Kliknij Connect
  8. Kliknij zakładkę Update
  9. Kliknij przycisk Update
  10. Jeśli wystąpi konflikt, należy usunąć wszystkie lokalne wersje
  11. Czekać aż aktualizacja się zakończy
  12. Jesteś gotowy do pracy

Czytaj dalej o szczegółowych informacjach na temat skutecznego codziennego korzystania z Asset Server.

Podstawy pracy

Podczas korzystania z Asset Server w zespole wieloosobowym, nie jest dobrą praktyką, aby aktualizować wszystkie zmiany aktywów z serwera po rozpoczęciu pracy. Najlepiej robić to pod koniec dnia lub kiedy skończysz pracę. Należy również dokonać zmian gdy w czymś poczyniłeś znaczne postępy, nawet gdy jest to w środku dnia. Dokonywanie zmian regularnie jest zalecane.

Zrozumienie Widoku Serwera

Jeśli okno Asset Server nie jest podłączone do głównego okna Unity możesz je włączyć za pomocą Window→Asset Server.

asset_20server-0.jpg

Przegląd zakładki

Widok Asset Server jest podzielony na zakładki: Overview, Update i Commit. Overview Pokaże Tobie różnice pomiędzy lokalnym projektem, najnowszą wersją na serwerze szybko możesz zapisać lokalne zmiany lub pobrać najnowsze aktualizacje projektu. Zakładka Update pokaże najświeższe zdalne zmiany na serwerze i pozwoli je pobrać do lokalnego projektu. Commit umożliwia stworzenie Changeset i zaangażować je na serwerze do pobrania przez innych.

Łączenie się z Serwerem

Zanim będziesz mógł korzystać z zasobów serwera, należy się na początku z nim się połączyć. Aby to zrobić naciśnij zakładkę/przycisk Connection który przełączy Ciebie do ekranu połączenia:

asset_20server-1.jpg

Asset Server - ekran połączenia

Tutaj musisz wpisać:

  1. Adres serwera
  2. Nazwa urzytkownika
  3. Hasło

Klikając Show projects możesz zobaczyć dostępne projekty dostępne na serwerze, i wybrać z którym chciał byś się połączyć i kliknąć Connect. Pamiętaj że Login i Hasło możesz uzyskać od administratora systemu. Administrator systemu tworzy konta podczas instalacji Asset Server.

Aktualizacje z Serwera

Aby pobrać wszystkie aktualizacje z serwera, wybierz zakładkę Update w widoku serwera, a zobaczysz listę najnowszych zmian jakie zostały wprowadzone. Po wybraniu jednej z nich możesz zobaczyć co zostało zmienione w projekcie, pod warunkiem że została rozesłana o tym wiadomość. Kliknij Update aby zacząć pobierać wszystkie zmiany (Changeset).

asset_20server-2.jpg

Zakładka aktualizacji

Zapisywanie zmian na serwerze

Po wprowadzeniu zmian do projektu lokalnego i chcesz zapisać te zmiany na serwerze należy użyć zakładki Commit.

asset_20server-3.jpg

Zakładka Commit

Teraz będziesz mógł zobaczyć jakie zmiany poczyniłeś w projekcie lokalnym od ostatniej aktualizacji i wybrać te które chcesz zapisać na serwerze. Możesz dodać zmiany w polu changeset lub przy pomocy przycisków umieszczonych poniżej pola wiadomości commit (Commit Message) Pamiętaj aby w polu wiadomości wpisać informacje które pomogą tobie porównać wersje lub powrócić później do wcześniejszych wersji ( o tym dowiesz się w dalszej części artykułu).

Rozwiązywanie konfliktów

Podczas gdy wielu ludzi pracuje na tym samym zbiorze danych, generuje to konflikty i nie da się przed tym uchronić. Niem ma jednak powodów do paniki! Jeśli dojdzie do takiej sytuacji, że zaistnieje konflikt podczas aktualizacji projektu zostanie on przedstawiony w okienku Conflict Resolution

asset_20server-4.jpg

Ekran rozwiązywania konfliktów

Tutaj można zobaczyć każdy konflikt i jakie opcje są dostępne aby rozwiązać każdy indywidualny konflikt. Dla pojedynczych konfliktów można wybrać Skip Asset (Pomiń aktywo, spowoduje to pominięcie danego aktywa i nie zostanie on pobrany z serwera), Discard My Changes (Odrzuć moje zmiany, wybranie tej opcji spowoduje całkowite zastąpienie lokalnych aktywów) lub Ignore Server Changes (Ignoruj ​​zmiany serwera, zaś ta opcja spowoduje ignorowanie innych zmian wprowadzonych aktywów i po aktualizacji będzie można wysłać swoje lokalne zmiany) dla każdego konfliktu. Dodatkowo można wybrać Merge dla aktywów tekstowych i skryptowych, aby scalić wersję serwerową z lokalną.

Uwaga: Jeśli zdecydujesz się odrzucić zmiany, składnik aktywów zostanie zaktualizowany do najnowszej wersji z serwera. Jeśli chcesz odzyskać aktywa takie jakie były zanim rozpocząłeś pracę, należy powrócić do konkretnej wersji

Jeżeli napotkasz konflikt podczas popełniani zmian lokalnych, Unity odmówi zatwierdzenia zmian i poinformuje że wystąpił konflikt. Aby rozwiązać konflikt wybierz Update. Lokalne zmiany nie zostaną automatycznie nadpisane. W tym momencie pojawi się okno dialogowe Conflict Resolution i możesz postemplować zgodnie z powyższego akapitu (o tym więcej w dalszej części artykułu o przywracaniu aktywów).

Przeglądanie historii i przywracanie aktywów

Asset Server przechowuje wszystkie wszystkie przesłane wersje aktywów w swojej bazie danych, dzięki czemu można przywrócić lokalną wersję projektu do wersji wcześniejszej. Możesz wybrać przywrócenie całego projektu lub pojedynczych plików. Aby powrócić do starszej wersji projektu lub assetu należy wybrać zakładkę Overview i kliknąć przycisk Show History w sekcji Asset Server Actions. I Twoim oczom ukarze się lista plików do przywrócenia i możesz teraz przywrócić cały projekt lub pojedyncze pliki do starszej wersji.

asset_20server-5.jpg

Okno dialogowe Historii

Tutaj można zobaczyć numer wersji i dodane komentarze do każdej wersji składnika aktywów lub projektu. To jest jeden z powodów dlaczego komentarze są pomocne. Wybierz dowolny składnik assetu aby zobaczyć jego historię Entire Project dla zobaczenia zmian dokonanych w projekcie. Znajdź to czego potrzebujesz. Można wybrać całe zmiany lub lub dane składniki assetu w wersji. Następnie wystarczy kliknąć przycisk Download Selected File aby pobrać kopię wybranej wersji. Kliknij Revert All Project aby przywrócić cały projekt do wybranej wersji.

Przed przywróceniem, sprawdź czy są jakieś różnice między lokalną wersją a wersją serwera, zmiany te zostaną utracone gdy wersja jest przywracana.

Jeśli tylko chcesz porzucić zmiany dokonane w kopii lokalnej, nie trzeba przywrócić. Można odrzucić te lokalne modyfikacje wybierając Discard Changes w oknie głównym serwera aktywów. I można natychmiast pobrać aktualną wersję projektu do lokalnego projektu.

Porównywanie wersji aktywów

Jeśli jesteś ciekawy i chcesz zobaczyć różnicę pomiędzy dwiema wersjami aktywów możesz jawnie je porównać. Aby to zrobić otwórz okno History wybierz wersję i aktywo, które chcesz porównać i naciśnij Compare to Local Version. Jeżeli konieczne jest porównanie różnych kolekcji przeglądanych aktywów naciśnij PPM na nim i wybierz z menu kontekstowego Compare to Another Revision następnie znajdź zmiany które chcesz porównać i wybierz je.

UWAGA: Ta funkcja wymaga zainstalowanego wsparcia obsługi plików diff/merge. Narzędzia wspierające:

Dla Windows:

Dla Mac OS X:

Odzyskiwanie usuniętych aktywów

Usunięcie lokalnego assetu lub z serwera nie będzie w rzeczywistości usuniętym trwale assetem. Tak jak każda poprzednia wersja składnika aktywów może zostać odtworzone dzięki okienku historii z zakładki Overview.

asset_20server-6.jpg

Okno dialogowe historii

Rozwiń pozycję Deleted Assets, znajdź i wybierz asset z listy i naciśnij Recover, wybrane aktywa zostaną pobrane i ponownie dodana do lokalnego projektu. Jeśli folder skąd został usunięty asset nadal istnieje zostanie on przywrócony do pierwszej lokalizacji, jeśli nie istnieje zostanie dodany do folderu głównego projektu Asset.

Szkolenie z Asset Server zakończone

Teraz powinieneś być wyposażony w potrzebną wiedzę do rozpoczęcia skutecznego korzystania z Asset Server. Dostań się do niego i nie zapomnij podstaw przepływu pracy. Zatwierdzaj często zmiany i nie bój się niczego utracić.


Poprzedni Następny

unity_manual/asset_server.txt · ostatnio zmienione: 2012/09/30 11:39 (edycja zewnętrzna)
Recent changes RSS feed Debian Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki